Broken API method Capabilities of Virtual Accounts?

Hello, I’m having issues whit this method

If I make the call with exactly the example data:
/v1/issuing/bankaccounts/capabilities/?country=sg&currency=sgd

I get this error:

  status: {
    error_code: 'ERROR_GET_ISSUING',
    status: 'ERROR',
    message: "The request tried to retrieve a virtual account number issued to a wallet, but the ID of the object was not recognized. The request was rejected. Corrective action: Provide the ID of a valid Virtual Account Number object, a string starting with 'issuing_'.",
    response_code: 'ERROR_GET_ISSUING',
    operation_id: 'd3d7d8c1-71c4-4288-8cd2-194785d3085d'
  }

Wich doesn’t make any sense to me. Am I doing something wrong?

BTW there is a mistake in the example of this method, there is a missing question mark in the URL right before the query params:
// Request URL: GET https://sandboxapi.rapyd.net/v1/issuing/bankaccounts/capabilities/country=sg&currency=sgd

Could be this also due to this note?:
Note: To use this feature, contact Rapyd Client Support .

I’m in Sandbox BTW

remove a ‘/’ so you get /capabilities?countr... instead of /capabilities/?countr...

Already tried that before posting :slight_smile:

same error

HI @dlupo

In fact, the endpoint needs the country as a path like this (and does not need the currency):

/v1/issuing/bankaccounts/capabilities/sg

The endpoint will return the list of supported currencies for that country.

We have asked our team to update the documentation. Thanks for pointing this out! :slight_smile:

2 Likes

Thank you, it works now! (I also updated my Node SDK with the correct URL if somebody needs it)

BTW, if you use the method with an unsupported country, you get an error like this:

{
  status: {
    error_code: 'ERROR_GET_GATEWAY_CAPABILITY',
    status: 'ERROR',
    message: '',
    response_code: 'ERROR_GET_GATEWAY_CAPABILITY',
    operation_id: '50b6e20d-3011-483b-8aca-b7fe14c154b7'
  }
}

Is this the expected behavior?
For my hackathon entry, I took the result from Rapyd dashboard endpoint (https://dashboard.rapyd.net/v1/merchants-portal/issuing/bankaccounts/get-iban-supported-countries) and created my own mockup version, using those countries, since with them the capabilities endpoint works with no issues, hope that’s ok.

2 Likes